May 29, 2003
Reaction score
Alrighty, this is more of a software problem then hardware. I dont know much about networking and ports and such, but I have cable internet and i use a router to share the connection between two computers. When i try to use the DCC send option on IRC it times out. Ive read why, but i havent found how to fix it. Some guys said i had to "open the port," i said "how" then he said "$120 before i go any farther" then i said "**** you"
Its not just on IRC, its on AIM and MSN too, how do i fix it so i can send files? pwease help me, Im bad on the software side of things, im more on the hardware side.
you use a router for two comps?
are you trying to send files to someone on irc, or to your other comp?
what OS are you running?

I have a network setup with one of my other comps, and they share a connection (this one connects through the other via crossover cable (12 bucks for 15ft) they conect directly via 2 ethernet cards (really inexpensive network option), and I have had no problems at all. although both comps run winxp pro. and Im using ADSL.
Sorry, i shoulda cleared that up, Im using XP Pro, Im not trying to network my computers together, I cant send to anyone over the internet. BTW i paid $25 for 50ft of CAT5, expensive shit.
are you running any firewall software? popup blockers, etc?
firewalls kill IRC, ICQ, and most other file transfer progs.
winxp pro tries to firewall all your connections by default, so if you havent checked for it, you should.
what router are you using? and does it have any firewall capabilities built into it?
check to see that you have your router's latest firmware.
I havent dealt much with routers, Im just running through some logical steps, maybe something you forgot. just trying to help :)
I will search on the internet a lil more, maybe one of my friends knows more.
My router has a biult in firewall and im using Zone Alarm
that may be your problem, everyone I knew (when I was an irc junky) that used firewalls etc, had problems with dcc in irc, Iqc, Aim etc
try disabling it, if only for the duration the DCC
alternatively you could try the above link and see if that works for you, although I dont think it goes through the procedure for ICQ and your other progs.
hope that helps, let me know if you have any progress
I went through everything in that link. But how do i disable the hardware Firewall on the router? Hit it with a hammer?
Ah, it was on the setup on the webpage to disable it. I restarted my computer, i hope it will work now :cheese:
Don't forget to check the built in firewall XP has.
Right click My network places -> Properties

Right click the connection ->

Click the advanced tab)

And it wouldn't suprise me at all if Zonealarm was killing it.
What router are you using?
Don't disable everything on the firewall except as proof on concept, that everything else is good.
Zone Alarm should prompt you for a new port when it happens, but you'll need that opened as well. I would suggest shutting down the zone alarm and getting it to work through just the router's security. Once successful bring up zone alarm and work out that level.

You want to open up the ports but you need to know if they are UDP or TCP ports. And you may need to distinguish that the ports need to be open in both directions--since firewalls pay attention to which direction is allowed to setup a connection.